www.gsx.com | log in | register

Last update: . Author: GSX Support (Yann) .

GSX Web Enabler JAVA Applet Not Running After Upgrading Firefox to Version 52

After upgrading Mozilla Firefox to version 52 or above, GSX Web Enabler no longer loads. This is caused by the JAVA Applet not running in Firefox version 52+ as NPAPI plugins are now deemed a source of performance problems, crashes, and security incidents for Web users and therefore disabled.

Follow this article for a workaround by using the alternate ESR release of Firefox version 52 or by modifying the Firefox configuration.

GSX Web Enabler | Mozilla Firefox 52+ | Java 

Symptoms

  • GSX Web Enabler does not load.
  • No Java plugin detected.
  • Your browser is completely ignoring the <APPLET> tag!

How to Solve the Issue

Utilize an alternate browser supporting JAVA plugins. 

Possible Workaround

Download and install the Firefox 52 Extended Support Release (ESR) found here.

If you are unable to install the Firefox 52 ESR version, enable the JAVA Applet to run by modifying your current Firefox 52 configuration:

Use caution when modifying Firefox configuration files.
  1. Open Firefox.
  2. In the Address Bar, type:
    • about:config
  3. Right-Click anywhere under Preference Name selecting New - Boolean:
    New_Boolean.png
  4. Enter the following preference name:
    • Plugin.load_flash_only Enter_the_preference_name.png
  5. Set the value to false:
    set_to_false.png
  6. Restart Firefox.

The JAVA Applet and GSX Web Enabler pages will now load successfully.

Related Articles:

NPAPI Plugins in Firefox



Not finding what you are looking for?

Have more questions? Submit a request


Was this article helpful?

0 out of 0 found this helpful