www.gsx.com | log in | register

Last update: . Author: Cyril LEROY .

GSX Monitor & Analyzer Install/Upgrade Issues: Windows XP needs Service Pack 3 or later

While installing GSX Monitor and Analyzer 10.x.x, executing the installer fails with error Installation on Windows XP needs Service Pack 3 or later regardless of the OS you are actually installing on. In this article we detail why this is happening and how to work around the issue.

Windows 7

Symptoms

  • The error message Installation on Windows XP needs Service Pack 3 or later pops up when running the setup wizard. 

How to Solve the Issue?

The reason that we see this error is that the OS is not recognizing the installer and misidentifying it as a Windows XP install package. It then automatically applies XP compatibility mode which causes it to fail to run correctly. We will remove the compatibility mode option, and let it run in the native OS using the steps below:

  1. Right-click on the GSX setup file (gsx_monitor_and_analyzer_X.X.X._setup.exe) and select Properties:

  2. Navigate to the Compatibility tab and clear the Run this program in compatibility mode for option:

  3. Run the GSX setup install wizard again. It should now pass the operating system check.
  4. Click on OK to confirm the settings.


Not finding what you are looking for?

Have more questions? Submit a request


Was this article helpful?

2 out of 2 found this helpful